Reconnaissance roms MAME

Ca marche pas. 6 heures de lutte, et rien, pas d'image, pas de son et une ampoule au pouce? Postez ici vos soucis et conseils, avec un peu de chance quelqu'un connaît la solution!

Reconnaissance roms MAME

Messagepar Mortipoil » 16 Oct 2016, 21:13

J'ai un problème avec MAME, j'ai toujours eu énormément de difficultés à faire reconnaître les roms.

Là par exemple j'essaie de jouer à un de mes jeux préférés de feu ma belle Saturn, Children of the atom.
J'ai téléchargé plusieurs fois la rom, soit en un fichier zip d'une vingtaine de Mo regroupant une vingtaine de fichiers, et aussi en téléchargeant une multitude de roms (eur, jap, asia, US...) histoire de m'assurer d'avoir les bonnes dans le lot.
Je ne renomme évidemment pas les fichiers, j'actualise la liste des roms dans MAME, et pour autant le jeu n'apparaît pas dans la liste "available".
Quand j'essaie de lancer le jeu à partir de la liste complète, j'ai droit à une erreur et fichiers manquants.
Pour le fun j'ai essayé d'autres roms d'autres jeux, et c'est toujours la même chose, aucune ne se lance.
J'utilise MAME Ui64 0.163 sous W10.

Quelqu'un aurait une idée?
ImageImageImageImage
Avatar de l’utilisateur
Mortipoil
Counter Stop
 
Messages: 5486
Inscrit le: 06 Sep 2012, 18:14
Localisation: Criss de tabarnak

Re: Reconnaissance roms MAME

Messagepar Mickey » 16 Oct 2016, 21:17

Ça fait un sacré moment que je ne pratique plus MAME mais ce ne serait pas tous simplement une histoire de bios CPS2 qui serait absent ?

Aucun jeu ne se lance, quel qu'il soit ?
Avatar de l’utilisateur
Mickey
King Fossile
 
Messages: 22261
Inscrit le: 28 Fév 2004, 00:08

Re: Reconnaissance roms MAME

Messagepar Mortipoil » 16 Oct 2016, 22:08

Si, des jeux présents dans le romset se lancent, comme certains KoF ou les Metal Slugs, mais quand je veux ajouter une nouvelle ROM ça ne fonctionne jamais.
Tu as peut-être raison concernant le BIOS cps2, cependant quand je lance un jeu il me nomme certains fichiers manquants (du genre xmcoa em3 missing, exemple fictif), comme si le zip était incomplet, tu crois que ça peut quand même être lié au BIOS?

Edit
Il semblerait qu'il s'agissait d'un problème de version de rom.
Je suis passé à la dernière version de Mame Ui64 en récupérant la rom v 0.178, et ça fonctionne.
Donc quand on veut récupérer une rom il faut s'assurer que ce soit la version correspondant à notre version de Mame (sinon j'ai l'impression que les roms ne sont plus fonctionnelles).

C'est quand même assez galère.
En tout cas je ne me lancerai pas là-dedans, je voulais juste me refaire un petit Children of the atom puisque j'ai le jeu original (de même que Marvel Super Heroes et X-Men vs Street Fighter en version jap) sur Saturn quelque part dans un carton je ne sais ou.

Merci de ton aide Mickey!
ImageImageImageImage
Avatar de l’utilisateur
Mortipoil
Counter Stop
 
Messages: 5486
Inscrit le: 06 Sep 2012, 18:14
Localisation: Criss de tabarnak

Re: Reconnaissance roms MAME

Messagepar Mickey » 17 Oct 2016, 08:58

Mortipoil a écrit:Donc quand on veut récupérer une rom il faut s'assurer que ce soit la version correspondant à notre version de Mame (sinon j'ai l'impression que les roms ne sont plus fonctionnelles).
Ah oui je n'avais pas pensé à ça, effectivement je me souviens que quand une nouvelle version de MAME sortait certaines roms ne fonctionnaient plus et il fallait les "mettre à jour".
Avatar de l’utilisateur
Mickey
King Fossile
 
Messages: 22261
Inscrit le: 28 Fév 2004, 00:08

Re: Reconnaissance roms MAME

Messagepar Yami9999 » 17 Oct 2016, 18:18

Tu as trouvé la solution avant que je réponde, mais oui, à force de galérer sur certains jeux, j'ai remarqué qu'il n'y a en final que deux cas de figure :

- Il manque un bios : si Mame t'affiche ce qu'il manque, le plus dur est fait ; tu as juste à copier-coller le nom d'un fichier sur Google, et normalement le bios sort tout seul.

- La rom n'est pas à jour : chose très courante en final, le mieux est d'essayer depuis différents sites. Les bios aussi peuvent être obsolètes ; je crois n'avoir eu ce problème qu'avec le neogeo.zip, mais j'ai mis du temps avant de comprendre d'où ça venait.

Bon après, il y a toujours les jeux non ou mal émulés, mais ils sont souvent annoncés en rouge bien visible. :D
Avatar de l’utilisateur
Yami9999
Shmuppeur turgescent
 
Messages: 4275
Inscrit le: 05 Juin 2012, 23:25


Retour vers Au secours !

Qui est en ligne ?

Utilisateur(s) parcourant actuellement ce forum : Aucun utilisateur inscrit et 1 invité